Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Hung Dx
Problem with Open Search On Liferay 6.1?
September 19, 2012 7:52 PM
Answer

Hung Dx

Rank: New Member

Posts: 1

Join Date: September 8, 2011

Recent Posts

Hi everyone!
I have a problem when adding search apabilities to a custom portlet on Liferay 6.1 CE GA1
by following this wiki post http://www.liferay.com/community/wiki/-/wiki/Main/Adding+search+capabilities+to+a+portlet

1.Create class CustomIndexer to index my custom entity.
2..Create class CustomOpenSearchImpl by extend HitsOpenSearchImpl.
3.Add <indexer-class>CustomIndexer </indexer-class> and <open-search-class>CustomOpenSearchImpl </open-search-class> to liferay-portlet.xml in my custom portlet
4.Update AssetEntry and invoke index/reindex method when add/update/delete custom entity on class CustomEntityLocalServiceImpl.
5.Enable Display Open Search Results checkbox on search portlet configuration page.

But my custom entity is not searchable from search portlet.
So please help me on this problem?
Brian Scott Schupbach
RE: Problem with Open Search On Liferay 6.1?
March 4, 2013 7:58 AM
Answer

Brian Scott Schupbach

Rank: Expert

Posts: 329

Join Date: October 23, 2008

Recent Posts

Hi Hung,

Did you ever get this figured out? I'm using GA2
Rahul Pande
RE: Problem with Open Search On Liferay 6.1?
March 15, 2013 12:43 AM
Answer

Rahul Pande

Rank: Regular Member

Posts: 229

Join Date: July 6, 2010

Recent Posts

Hi Hung,

In Liferay 6.1, Faceted search is used instead of Open search. You can find more information about it here

Thanks
Rahul